Αν έχετε έναν ιστότοπο φτιαγμένο με Drupal θα πρέπει να σταματήσετε ό,τι κάνετε τώρα και να εγκαταστήσετε άμεσα την ενημερωμένη έκδοση ασφαλείας λόγω ενός εξαιρετικά κρίσιμου κενού ασφαλείας.

Η επείγουσα έκδοση κώδικα αντιμετωπίζει μια σοβαρότατη ευπάθεια του Drupal που επιτρέπει την απομακρυσμένη εκτέλεση κώδικα σε “πολλαπλά υποσυστήματα” του λογισμικού και την πλήρη παραβίαση και παράνομο έλεγχο του ιστότοπου.

Ένας ανώνυμος κακόβουλος χρήστης μπορεί να επιτεθεί στον Drupal ιστότοπό σας από οποιαδήποτε ιστοσελίδα, χωρίς καν να συνδεθεί ή να έχει οποιαδήποτε προνόμια. Έτσι μπορεί να αναλάβει τον έλεγχο του ιστότοπου σας ώστε να διαγράψει ή να αλλάξει ιδιωτικά και δημόσια δεδομένα.

Με άλλα λόγια, πρόκειται για μια πραγματικά σοβαρή ευπάθεια του Drupal και έχει σκορ 21/25 (Highly Critical). Διαβάστε περισσότερα για την ευπάθεια του Drupal.

Πως καλύπτεται το κενό ασφάλειας του Drupal;

Αναβαθμίστε στην πιο πρόσφατη έκδοση του Drupal 7 ή 8 ή εγκαταστήστε τις διορθώσεις (patches). Tο κενό υπάρχει και στο Drupal 6 που δεν υποστηρίζεται πλέον από την κοινότητα, όμως το Drupal 6 Long Term Support project έχει ετοιμάσει διορθώσεις. Συνιστούμε να αναβαθμίσετε άμεσα από το Drupal 6 στην έκδοση 8.

Πως προστατεύει η DNHOST τους πελάτες της;

Στην DNHOST έχουμε εφαρμόσει δύο ειδικούς κανόνες στον Web Application Firewall (WAF) που έχουμε στους shared hosting / reseller-hosting / semi-dedicated hosting servers μας, για την προστασία από το συγκεκριμένο κενό ασφαλείας του Drupal.

Το Drupal μου παραβιάστηκε, τι να κάνω;

Ανεξαρτήτως αν το Drupal σας παραβιάστηκε από ετούτο ή από παλαιότερο κενό ασφαλείας, ακολουθήστε τον γενικό οδηγό για “hacked” sites και φροντίστε να κρατάτε πάντα το Drupal αναβαθμισμένο στην τελευταία διαθέσιμη έκδοση.

 

Γιάννης
Author

Συνιδρυτής της DNHOST, με πάθος για το διαδίκτυο, τη μουσική και τη φύση & συμβάλλει στη δημιουργία και βελτίωση των υπηρεσιών μας!

Γράψε ένα σχόλιο

* Απαιτείται αποδοχή

*

Αποδοχή